Investigating route issues

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 11:17 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2025 - 10:24 PDT

Investigating

We are currently investigating an issue with routes, including route creation and recommendations.
Posted Jun 05, 2025 - 09:17 PDT
This incident affected: Strava.com.