Investigating delay in processing new activities.
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 28, 2019 - 12:57 PST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jan 28, 2019 - 12:30 PST
This incident affected: Upload.