Weather Data Delayed
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Apr 04, 2023 - 03:35 PDT
Monitoring
We are experiencing an issue that is causing delays in adding Weather data to newly uploaded activities. We are monitoring the situation now.
Posted Apr 03, 2023 - 22:40 PDT
This incident affected: Strava.com, API, and Upload.