Investigating site performance and availability issues
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Dec 17, 2022 - 16:20 PST
Monitoring
A fix for our delays in goal updates has been implemented and we are monitoring the results
Posted Dec 17, 2022 - 16:07 PST
Investigating
We are currently investigating an issue that is causing delays in updating Athletes' progress in their goals.
Posted Dec 17, 2022 - 15:28 PST
This incident affected: Strava.com, API, and Upload.