Problems in receiving activities from Fitbit
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 22, 2019 - 13:29 PDT
Investigating
Problems in receiving activities from Fitbit. The Strava website and mobile apps are working as expected.
Posted 3 months ago. Jul 20, 2019 - 15:48 PDT
This incident affected: Upload.