Investigating site and mobile app outages
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 01:13 PDT
Update
Strava Beacon service has been restored. We are continuing to investigate degraded site performance.
Posted Sep 26, 2021 - 20:53 PDT
Investigating
We are currently investigating this issue. Strava Beacon is currently unavailable.
Posted Sep 26, 2021 - 20:31 PDT
This incident affected: Strava.com, API, and AWS.