Degraded Performance
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 17 days ago. Sep 01, 2019 - 11:32 PDT
Update
The site is now operational. Challenge Leaderboards are out of date and will be refreshed tonight.
Posted 18 days ago. Sep 01, 2019 - 09:33 PDT
Update
Some challenge related functionality is temporarily disabled.
Posted 18 days ago. Sep 01, 2019 - 07:14 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted 18 days ago. Sep 01, 2019 - 05:39 PDT
Update
We are continuing to investigate this issue.
Posted 18 days ago. Sep 01, 2019 - 04:59 PDT
Investigating
Our site is experiencing some degraded performance.
Posted 18 days ago. Sep 01, 2019 - 04:44 PDT
This incident affected: Strava.com.