Delays in receiving activities from Suunto
Incident Report for Strava
Resolved
Suunto activity uploads have resumed.
Posted 13 days ago. May 08, 2019 - 08:27 PDT
Monitoring
Delays in receiving activities from Suunto. The Strava website and mobile apps are working as expected.
Posted 14 days ago. May 07, 2019 - 10:29 PDT