Delayed segment leaderboard updates
Incident Report for Strava
Update
Segment leaderboard updates are still delayed.
Posted Sep 09, 2021 - 08:59 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2021 - 09:50 PDT
Investigating
Segment leaderboard updates are currently delayed. They will be updated shortly.
Posted Aug 27, 2021 - 07:21 PDT
This incident affects: Strava.com and API.