Google Maps Outage impacting Mobile and Web Platforms
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 08:34 PDT
Identified
We are aware that Google Maps is currently experiencing issues across multiple applications and platforms. This is causing activity recording to crash and some features on the application to not work properly.
Posted Apr 23, 2020 - 14:04 PDT
This incident affected: Strava.com.