Investigating delayed notifications
Incident Report for Strava
Resolved
We have implemented a fix for this problem and will continue to monitor our systems.
Posted Jul 12, 2022 - 09:40 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2022 - 09:18 PDT
Update
We are continuing to investigate this issue.
Posted Jul 12, 2022 - 09:09 PDT
Investigating
We are currently investigating this issue.
Posted Jul 12, 2022 - 09:08 PDT
This incident affected: Strava.com.