Uploads from Garmin are currently delayed.
Incident Report for Strava
Resolved
This incident has been resolved. If you need any further assistance please contact Strava Support: https://support.strava.com/hc/en-us/articles/216917777-How-do-I-contact-Strava-Support-
Posted Feb 28, 2021 - 19:55 PST
Update
We are receiving activity uploads taken between 1pm-2:40pm UTC from Garmin Connect, though some uploads may still be delayed. We are continuing to monitor the issue.

Garmin sync troubleshooting suggestions: https://support.strava.com/hc/en-us/articles/216934427-Troubleshooting-Garmin-sync-issues
Posted Feb 28, 2021 - 15:44 PST
Monitoring
We are receiving activity uploads from Garmin Connect, though some uploads may still be delayed. We are continuing to monitor the issue.

Garmin sync troubleshooting suggestions: https://support.strava.com/hc/en-us/articles/216934427-Troubleshooting-Garmin-sync-issues
Posted Feb 28, 2021 - 08:01 PST
Update
We are continuing to investigate this issue.
Posted Feb 28, 2021 - 06:35 PST
Investigating
We are currently investigating this issue.
Posted Feb 28, 2021 - 05:58 PST
This incident affected: Strava.com, API, and Upload.