Strava site and apps are down
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 10:01 PDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2021 - 09:58 PDT
This incident affected: Strava.com, API, Upload, and Strava Local.