The site and apps are down
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Oct 25, 2024 - 09:42 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 25, 2024 - 09:16 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 25, 2024 - 08:55 PDT
Investigating
We are currently investigating this issue.
Posted Oct 25, 2024 - 08:18 PDT