Notifications Down
Incident Report for
Strava
Resolved
This incident has been resolved.
Posted
May
16
,
2025
-
20:08
PDT
Monitoring
A fix has been implemented and we are currently monitoring it.
Posted
May
16
,
2025
-
20:07
PDT
Identified
The issue has been identified and fix is being implemented.
Posted
May
16
,
2025
-
20:05
PDT
Investigating
We are investigating an outage with some in app notifications.
Posted
May
16
,
2025
-
19:18
PDT
This incident affected: Strava.com.
×
Subscribe to Incident
Subscribe to updates for
Notifications Down
via . You'll receive .