AWS Connectivity Issues
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 05:44 PDT
Identified
We are experiencing elevated latency and error rates due to an issue with Amazon AWS, an underlying service provider
Posted Jul 28, 2020 - 02:42 PDT
This incident affected: Strava.com, API, Upload, and AWS.