Strava Android Beta v304.7 is currently unstable
Incident Report for Strava
Resolved
This incident has been resolved. Beta version 304.8 is now live and addresses this issue.
Posted Apr 21, 2023 - 13:52 PDT
Identified
We are aware of the Android mobile app crashing for users on v304.7 and are working on a fix. In the meantime, please download the production release v303.9 in the Google Store.

We appreciate your patience!
Posted Apr 20, 2023 - 13:05 PDT