Investigating Strava degraded performance
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 13, 2019 - 08:55 PST
Monitoring
A fix has been implemented and we are monitoring site performance.
Posted 7 months ago. Jan 13, 2019 - 06:37 PST
Investigating
Our engineers are aware of degraded performance of Strava.com and are investigating.
Posted 7 months ago. Jan 13, 2019 - 05:35 PST
This incident affected: Strava.com and API.