Investigating site and mobile app outages

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 11:34 PDT

Monitoring

We are monitoring results of the implemented fix.
Posted Mar 27, 2025 - 11:18 PDT

Identified

The issue has been identified and a fix has been implemented.
Posted Mar 27, 2025 - 11:17 PDT

Investigating

We are currently investigating issues with viewing activities and general latency throughout our web and mobile apps.
Posted Mar 27, 2025 - 11:07 PDT
This incident affected: Strava.com.