Login Issues

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 12:50 PST

Identified

Some of our users are experiencing issues logging into their account. We are aware of the issue and are working on a solution.
Posted Mar 03, 2026 - 09:29 PST
This incident affected: Mobile applications and Strava.com.