Delayed Garmin Uploads
Incident Report for
Strava
Resolved
This incident has been resolved
Posted
Sep
18
,
2024
-
09:50
PDT
Monitoring
We are currently monitoring the incident
Posted
Sep
18
,
2024
-
09:37
PDT
Investigating
We are currently investigating an issue with upload times for Garmin activities
Posted
Sep
18
,
2024
-
08:52
PDT
This incident affected: Upload.
×
Subscribe to Incident
Subscribe to updates for
Delayed Garmin Uploads
via . You'll receive .