Investigating issue with some newly created activities
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 10 months ago. Dec 10, 2018 - 15:57 PST
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Dec 10, 2018 - 12:42 PST
This incident affected: Strava.com and API.