Problems in receiving activities from Suunto
Incident Report for Strava
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 10, 2019 - 08:33 PDT
Update
We are continuing to monitor for any further issues.
Posted 2 months ago. May 10, 2019 - 16:46 PDT
Monitoring
Problems in receiving activities from Suunto. The Strava website and mobile apps are working as expected.
Posted 2 months ago. May 10, 2019 - 16:38 PDT