Site performance and availability issues

Incident Report for Strava

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 22:50 PDT

Investigating

We are investigating site performance and availability issues
Posted Apr 20, 2026 - 20:12 PDT
This incident affects: Mobile applications and Strava.com.