Degraded Performance: Activity Uploads

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Sep 27, 2026 - 11:24 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 27, 2026 - 10:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 27, 2026 - 09:32 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 27, 2026 - 09:21 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 27, 2026 - 09:20 PDT

Identified

The Strava app is currently unavailable for most users. We're aware of the issue and actively working to restore the service.
Posted Sep 27, 2026 - 08:56 PDT

Update

We are continuing to investigate this issue.
Posted Sep 27, 2026 - 08:48 PDT

Investigating

We're currently investigating reports of delays and failures when uploading activities. Some users may experience longer-than-normal processing times or upload errors.
Posted Sep 27, 2026 - 08:17 PDT
This incident affected: Mobile applications, Strava.com, API, and Upload.