Upload processing delays
Incident Report for Strava
Resolved
The issue delaying uploads has been resolved
Posted Dec 13, 2023 - 13:11 PST
Investigating
We are currently investigating an issue causing uploads to be delayed in processing.
Posted Dec 13, 2023 - 12:39 PST
This incident affected: Upload.