Upload & Web Outage
Incident Report for
Strava
Resolved
This incident has been resolved.
Posted
Oct
20
,
2025
-
15:38
PDT
Monitoring
We are monitoring improvements to upload and overall app latency.
Posted
Oct
20
,
2025
-
12:48
PDT
Investigating
We are seeing delays in uploads and increased latency for various features stemming from AWS outages.
Posted
Oct
20
,
2025
-
11:26
PDT
This incident affected: Strava.com, API, Upload, and AWS.
×
Subscribe to Incident
Subscribe to updates for
Upload & Web Outage
via . You'll receive .