Investigating site performance and availability issues
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Mar 03, 2024 - 11:02 PST
Identified
There is an issue with athlete search on the platform, affecting some users. We are working on a fix.
Posted Mar 03, 2024 - 09:56 PST
Update
We are continuing to monitor for any further issues.
Posted Mar 03, 2024 - 09:55 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2024 - 06:37 PST
Investigating
We are currently investigating this issue.
Posted Mar 03, 2024 - 05:26 PST
This incident affected: Strava.com, API, and Upload.