Investigating site and mobile app outages
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 11:27 PST
Investigating
We are currently investigating this issue.
Posted Mar 09, 2022 - 11:06 PST
This incident affected: Strava.com and API.