Delayed map rendering in feed and routes

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 15:37 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 14:36 PDT

Investigating

We are looking into continued delays in generating activity maps and route images that are a result of the previous system outages.
Posted Oct 20, 2025 - 08:53 PDT
This incident affected: Strava.com.