Goal and challenge completion achievements are delayed
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Jun 19, 2024 - 21:00 PDT
Monitoring
We've implemented a fix and are monitoring to verify goal updates and challenge completion achievements are up-to-date.
Posted Jun 19, 2024 - 20:52 PDT
Identified
We've identified an issue causing delays to goal progress updates and challenge completion achievements on mobile and web. Your Strava goals and challenges may not reflect your most recent activities as a result of this issue. We're working to resolve this issue right away.
Posted Jun 19, 2024 - 20:38 PDT
This incident affected: Strava.com.