Investigating site performance and availability issue with historical Garmin activities

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 06:55 PDT

Identified

We are investigating an issue affecting retrieval of historical activities from Garmin
Posted Mar 22, 2025 - 01:01 PDT
This incident affected: Strava.com, API, and Upload.