Delayed Garmin Syncs

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Mar 19, 2026 - 06:10 PDT

Investigating

We are experiencing delays in Garmin activity imports into Strava. We are investigating the issue.
Posted Mar 19, 2026 - 05:56 PDT
This incident affected: Mobile applications, Strava.com, API, and Upload.