Site slowness and delays
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 23, 2019 - 08:33 PST
Monitoring
The underlying issue has been fixed. Some site actions will be delayed as things recover.
Posted 7 months ago. Feb 23, 2019 - 06:09 PST
Identified
We have identified a delay in some requests and background processing.
Posted 7 months ago. Feb 23, 2019 - 06:01 PST
This incident affected: Strava.com, API, and Upload.