Maps display issue
Incident Report for
Strava
Resolved
This incident has been resolved.
Posted
May
20
,
2026
-
12:32
PDT
Monitoring
A fix has been implemented for display of maps on the feed and we are monitoring the results.
Posted
May
20
,
2026
-
12:26
PDT
Identified
An issue has been identified with maps not displaying properly and we are working on a fix.
Posted
May
20
,
2026
-
11:21
PDT
This incident affected: Mobile applications and Strava.com.
×
Subscribe to Incident
Subscribe to updates for
Maps display issue
via . You'll receive .