Issue displaying maps on Activity Feeds
Incident Report for Strava
Resolved
The incident has been resolved and map images should be back to normal.
Posted Jun 02, 2023 - 13:53 PDT
Identified
We are currently experiencing issues rendering map images on our Activity Issues. We have identified the upstream issue and will continue to post updates as we get them.
Posted Jun 02, 2023 - 13:25 PDT
This incident affected: Strava.com.