Delays in activity updates & notifications
Incident Report for
Strava
Resolved
This incident has been resolved.
Posted
Jan
12
,
2026
-
17:16
PST
Monitoring
We have implemented a fix and there should no longer be delays in activity updates and notifications. We will continue to monitor the situation.
Posted
Jan
12
,
2026
-
16:56
PST
Investigating
We are currently investigating this issue.
Posted
Jan
12
,
2026
-
16:41
PST
This incident affected: Strava.com, API, and Upload.
×
Subscribe to Incident
Subscribe to updates for
Delays in activity updates & notifications
via . You'll receive .