Activity Uploads delayed
Incident Report for
Strava
Resolved
This incident is resolved.
Posted
Jan
26
,
2026
-
13:55
PST
Monitoring
We are currently monitoring a fix
Posted
Jan
26
,
2026
-
13:16
PST
Investigating
Activity uploads are currently delayed. We are investigating the issue.
Posted
Jan
26
,
2026
-
12:51
PST
This incident affected: Mobile applications, API, and Upload.
×
Subscribe to Incident
Subscribe to updates for
Activity Uploads delayed
via . You'll receive .