Site Degraded
Incident Report for Strava
Resolved
This incident has been resolved.
Posted Jan 15, 2020 - 14:19 PST
Identified
The issue has been identified and a fix is being worked on.
Posted Jan 15, 2020 - 14:08 PST
Update
We are continuing to investigate the cause of our mapping issue and have issued a maintenance window to facilitate investigation.
Posted Jan 15, 2020 - 13:57 PST
Investigating
We're aware of a problem preventing activity maps from displaying. We are actively working on the issue and appreciate your patience.
Posted Jan 15, 2020 - 13:34 PST
This incident affected: Strava.com.