Degraded Athlete Search Functionality
Incident Report for Strava
Resolved
Strava Athlete Search has returned to a fully operational state.
Posted May 30, 2020 - 07:07 PDT
Monitoring
Strava Athlete Search is currently degraded. The problem has been identified and a fix is in progress. The rest of the site is fully operational.
Posted May 30, 2020 - 05:03 PDT
This incident affected: Strava.com and API.