Delayed Goals Updates

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 07:41 PDT

Monitoring

We've identified the issue with delayed goal updates and are processing the backlog now.
Posted Oct 17, 2025 - 06:04 PDT

Investigating

We are currently experiencing a delay in updating athletes' progress towards their goals.
Posted Oct 17, 2025 - 04:28 PDT
This incident affected: Strava.com.