Certain Web-based features are down, Route Creation, Training Log, Heatmaps.
Incident Report for Strava
Resolved
Web products are back and operational
Posted Mar 23, 2024 - 14:21 PDT
Update
We are continuing to investigate this issue.
Posted Mar 23, 2024 - 14:05 PDT
Investigating
We're investigating an issue affecting multiple web products.
Posted Mar 23, 2024 - 14:05 PDT
This incident affected: Strava.com.