Uploads are currently delayed

Incident Report for Strava

Resolved

The upload delay incident has been resolved.
Posted Oct 20, 2025 - 09:25 PDT

Monitoring

We are monitoring improvements on most affected features, including uploads.
Posted Oct 20, 2025 - 07:39 PDT

Investigating

We are currently investigating an issue causing a delay in uploads.
Posted Oct 20, 2025 - 00:30 PDT
This incident affected: Strava.com, API, and Upload.