Site or App Feature Issues

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 10:08 PDT

Investigating

We are currently investigating this issue with Activities
Posted Mar 27, 2026 - 07:53 PDT
This incident affected: Mobile applications.