Feed activities not being updated

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 12:19 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2025 - 11:19 PDT

Investigating

We are currently investigating new activities not showing up in athletes' feeds.
Posted Apr 24, 2025 - 10:28 PDT
This incident affected: Strava.com.