Missing map images

Incident Report for Strava

Resolved

This incident has been resolved.
Posted Jan 04, 2026 - 11:16 PST

Update

We are looking into missing activity maps in the feed and other pages.
Posted Jan 04, 2026 - 10:33 PST

Investigating

We are looking into missing activity maps in the feed and other pages.
Posted Jan 04, 2026 - 10:28 PST
This incident affected: Strava.com.