Club leaderboards, challenge leaderboards, and uploads have returned to to normal operation. We are still monitoring goals and progress features to verify normal operation.
Posted Jul 12, 2024 - 18:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 12, 2024 - 17:58 PDT
Investigating
Investigating an issue causing delays to uploads and degraded experience for goals, club and challenge leaderboards, and progress features for some users.