Investigating issue with activity upload.
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 01, 2018 - 14:35 PDT
Update
Investigating slowness with processing activities from Garmin.
Posted 4 months ago. Aug 01, 2018 - 13:47 PDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Aug 01, 2018 - 12:27 PDT
This incident affected: Upload.