We are currently experiencing site issues
Incident Report for Strava
Resolved
This incident has been resolved.
Posted 12 months ago. Jul 31, 2016 - 21:21 PDT
Update
Strava is back.
Posted 12 months ago. Jul 31, 2016 - 19:44 PDT
Update
Strava is currently down. Addressing on the issue.
Posted 12 months ago. Jul 31, 2016 - 19:21 PDT
Update
Uploads coming from Garmin Connect and a subset of operations on Strava are still delayed. Working to resolve the issue.
Posted 12 months ago. Jul 31, 2016 - 15:36 PDT
Update
The site is back online. We are investigating continued delays in some background processing.
Posted 12 months ago. Jul 31, 2016 - 09:30 PDT
Investigating
Strava is currently experiencing unexpected site issues. We will update when we have more information on an expected resolution.
Posted 12 months ago. Jul 31, 2016 - 09:09 PDT