Garmin planned maintenance.
Incident Report for Strava
Resolved
Garmin appears to be back online.
Posted 6 months ago. Apr 14, 2018 - 21:50 PDT
Identified
Garmin is undergoing a planned maintenance. Garmin uploads to Strava will be delayed during this time.
Please see Garmin for more details: https://twitter.com/Garmin/status/985314258828349444
Posted 6 months ago. Apr 14, 2018 - 19:57 PDT